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Introduction

Microsoft Excel is a spreadsheet application that features calculation, graphing
tools and other features for manipulation of alphanumeric data. It displays a vast
area of cells organized in rows and columns, and each cell contains data or a
formula, with relative or absolute references to other cells. It can contain any
combination of types of data, but is most commonly used for:

e numerical data: financial, statistical, date & time related
* charts: visual representation of data
* lists: helpful for tracking lists of information/data

Microsoft Excel files are easily recognized by the “.xIs” (version 2003 and earlier
for Windows, 2004 and earlier for Mac) or “xlsx” (version 2007 for Windows,
2008 for Mac) file extensions at the end of the name.

Definitions:

* worksheet: single sheet of cells in 1,048,576 rows by 16,384 columns.
Used interchangeably with spreadsheet. You will probably never fill one
up or break it by putting too much into it.

* workbook: tabbed group of worksheets in a single file. The number of
sheets is limited only by the computing power of your computer.

* active cell: the cell bordered in dark, thick lines with a white background

* selecta cell (or cells): click on (or click and drag through) the cells you
wish to work with.

Cell labeling

Each cell is uniquely labeled and referred to by a combination of 1-3 letters
(from “A” to “XFD”) followed by a number from 1 to 1048576. You can tell what
cell you are working on by the display in the Name Box:

- CALE] rie CuiL
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Getting Started

Interface
Let’s look first at four principle parts of the Excel interface:

1. Menu Bar
2. Toolbar
3. Elements Gallery
4. Toolbox
Menu Bar

1. View menu: indicates with check marks which items are currently
visible. You can add or remove items here as you need.
0 Normal vs. Page Layout: can x
be changed from view menu == Sheetl +
or buttois in lower-left EE | P—— ReadyA-.
corner of screen. R
2. Preferences:
I In the menu bar at the top select Excel -> Preferences.

T

Excel Preferences

] Q|
Back/Forward Show All Search Excel Preferences
Authoring
~ ann - | /-'3
i 7/ i ©
General View Edit AutoCorrect Chart Color

Formulas and Lists
T = ZSUMIEZ]
33332 ﬁl =\ ! |
: \

SUMIF

Calculation Error Checking Custom Lists AutoComplete

Sharing and Privacy

E‘ c;a o Q s

Save Compatibility Security Feedback Gallery

»Cancell\ / OK

LI Select the “View” option. As you mouse over the different options
notice that an explanation appears at the bottom of the window.

O Click the “Show All” switch or the “Back” button.

LI Click on the “Compatibility” option. If you are working in a mixed
environment and want to automatically create documents in an
earlier version of Excel, here it the place to set that.
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Toolbar

Help

®0 0 - Workbook1
= 8 06 & o-e- 2- & Z. [0 @ o @
New Open Save Print Import Copy Paste Format ' | . AutoSum Sort A-Z Sort Z-A Gallery Toolbox Zoom
By default the Toolbar presents users’ most-frequently used commands in an
icon + text version. You can change this by Control-clicking on the bar, or
selecting View -> Customize Toolbars and Menus from the Menu bar.
Elements Gallery
[ Sheets l Charts { SmartArt Graphics | WordArt |
m ~ Area ~Bar Bubble Column Doughnut Line Pie Radar Stock Surface X Y (Scatter)
Insert Chart
omme | e | MY | N E A -
Microsoft has created tabbed “groups” of similar features. Adding software that
interacts with Office programs will create additional tabs or add to the “Add-Ins”
tab (if it already exists).
® O O Formatting Palette (S]]
Toolbox AN IR =]
Microsoft has added a “Toolbox” to the right of the ¥ Font
screen whose name changes depending on which set | yame: verdana =
of options you have selected. The “Formatting size: 10 M L
Palette” option opens by default. -
What’s changed in Excel? | AZ| A,
Since the 2004 version Excel has been made more > Number 1
robust. Changes include: T TR e
 Expanded from 65k to more than 1 million rows, | "erenal (= = ==
and from 256 to 16k columns per spreadsheet, Vertical: | = | = |mm| —
w}.n.ch required a new file format ("xlsx"), which | . B 2 (o[ B \
utilizes the eXtensible Markup Language or XML. - -
 Tables automatically include filtering. LT R R
* Increased formatting power: themes, more Indentation and Merge
colors, conditional formatting expanded from 4. Indent: 0 % M
* Using the Elements Gallery you can create new, » Borders and Shading |
professional looking charts. b Page Setup t
* Easier to create pivot tables. » Document Theme l
* Conditional formatting for identifying trends (ex.
top 10 items). \
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Tips for a mixed environment:
1. Learn how different versions interact. Comparison tool available at
Microsoft’s website (http://tinyurl.com/yhmmqgbv).
2. Create files in the most common version.

Keyboard shortcuts

To Press
Move right one cell Press the Tab key or the right arrow key
Move left one cell Press shift+Tab or the left arrow key
Press the Return key or the down arrow
Move down one cell key
Move up one cell Press shift+Return or the up arrow key.

Page Down (extended keyboard)

Move down one full screen fn key + down arrow (laptop)

Page Up (extended keyboard)

Move up one full screen fn key + up arrow (laptop)

Alt + Page Down (extended keyboard)

Move right one full screen Option + Page Down (for Mac)

Alt + Page Up (extended keyboard)

Move left one full screen Option + Page Up (for Mac)

Home (extended keyboard)

Move to beginning of row fn key + left arrow (laptop)

Control + Home (extended keyboard)

Move to beginning of sheet fn key + Control + left arrow (laptop)

Control + End (extended keyboard)

Move to end of data on sheet fn key + Control + right arrow

Move to end of current row Control + right arrow key

Move to end of current column | Control + down arrow key

Getting Started
Open the file “exercises.xlsx”. Click on the “Allowance” worksheet tab.

Exercise: teaching youth to save.

An older child wants an increase in allowance to buy a new video game.
We are going to demonstrate that s/he already makes enough money to
buy the game if they save for it.

1. In the “Other” row, enter any dollar amount under $10 for each of
the 4 weeks.

2. Type in the word “Total” just below the word “Other” in column A
and press “Tab” or the right arrow key to move to the next cell.

3. To instantly total a column or row of numbers in the active cell
just click on the sigma symbol in the formatting toolbar. After
viewing the formula to make sure it is correct press “Tab” or the
right arrow key to move to the next cell.

Microsoft 2008 for Mac SOME RIGHTS RESERVED
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4. Finish creating totals for each column. Then add a column title
after Week 4 labeled “Monthly Total”. Sum up the row horizontally
so the total is in that column.

5. To add the cents after the decimal and the dollar sign, click and
drag through all the cells containing the totals we created, then
click on the dollar sign in the Formatting Toolbar.

Formatting, Formulas and Functions

The next exercises developed for this workshop are built around a fictitious
medical consulting business with you as the owner. Click on the “Fees”
worksheet tab in your open workbook.

Formatting cells
* Make text headings fit: double-click each column’s right border beside the
letter heading
* Add decimals and commas by clicking on the comma button in the ’
Formatting Toolbar.
* Creating column headings centered in bold
o Select the cells with headings
o Click on the bold capital “B” and then on the center-text button in
the formatting bar. For more options use the “Format -> Cells...”
menu.

Formulas structure

A formula or other calculation structure always begins with and equals sign
(“="). In the case of a function it is followed by the name of the function with left
and right parentheses enclosing the cells being referred to.

For example,
=SUM(B2:B10)

will add up the numeric contents of cells B2 through B10. And the function
=AVG(C2:C21)

will calculate the average of the numeric contents of cells C2 through C21.

Adding totals faster:

* Adda “Q totals” row heading after “South” and use the sigma to total only
the first column.

* Fill Right: Making sure cell B6 is still selected, place your cursor at the
bottom-right corner of the cell. It will change to a dark plus sign (“4”).
Click and drag over 3 more columns and release the mouse button. Note
the “Auto Fill” icon that appears at the end of the row. This will allow you
to adjust your Fill Right as needed (Fill Right is a form of copy-and-paste.)

¢ (lick the check mark (Windows) or press Enter (both).
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* Adda “Y totals” column heading after “Fourth Quarter” and use the sigma
to total the first row of figures.

* Fill Down: Making sure cell F2 is still selected, place your cursor at the
bottom-right corner of the cell. It will change to a dark plus sign like
before. Click and drag down 3 more rows and release the mouse button.

Handling large worksheets

Inserting Rows, Columns and Sequential Numbers
Click on the “Rename” worksheet tab in your workbook. This spreadsheet shows
the top 40 pages visitors went to from the FAQ page on the Library’s website.

To add a single column to the left of the existing columns:

1. Click on column A to select the entire column.
2. Insert -> Columns. Now you have a blank column to the left of your data.

To insert rows:

* (lick on the heading for row 1 and drag through row 4
* Insert- > Rows. Now you have 4 additional blank rows for headings and
data.

Inserting Sequential Numbers:

* Type the following headings above your data:
o “Page Name” above column B.
o “URL” above column C.
o “Views” above column D.

* In the blank column to the left of your data, type the heading “Rank” just
to the left of “Page Name”, and then press “Enter” or “Return” to go down
just one row.

* Typea“l” in that row, press “Return”, and then type a “2” in the next row.
Click and drag to select the cells with “1” and “2” in them.

* Place your cursor on the bottom-right corner of the cell with a “2” in it. It
will change to a dark plus sign (“4”). Click and drag down column A to
the end of your data to fill in with sequential numbers.

Renaming Worksheets
To rename the “Rename” worksheet:

* Double-click on the “Rename” tab, or control + click and select “Rename”.
* Type “FAQ Stats” and press “Enter” or Return.

Keeping Headings in View
Click on the “News” worksheet tab in your workbook. This spreadsheet shows
data downloaded from a web server, with many, many columns and rows.
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* Freeze panes:
o To keep the row and column headings on the screen click on cell
B2.
o Window -> Freeze panes.
o Now when you scroll up/down or right/left the column and row
headings stay visible.
* Hiding columns
o Click and drag across columns C - D, or click on column C and shift
+ click on D.
o Right-click (or Control + click) on the selected columns and select
the “Hide” option. Columns C and D are now hidden, and columns
A and E have bold, blue lettering to show where columns have
been hidden.
o Toshow C & D, click and drag across columns A and E, right-click
(or Control + click) on the column headings and select “Unhide.”
You can now see all columns.
* To unhide columns:
o Click and drag across columns B & E

Click on the “Sales report1” worksheet tab in your workbook. This is a
spreadsheet listing sales orders for a company serving the US and the UK.

* To keep the headings on the screen, click on cell C1 and use “Freeze
panes.”
* Sorting data by column
o Clickon cell Al.
o Hold down the fn+Control+Shift keys and press the right arrow
key. All data is now selected. Release the Control and Shift keys.
o Data-> Sort
o Inthe “Sort” menu select “Order Amount” and “Descending” to see
who had the largest orders. If you have selected the row of
headings, make sure the “My list has” option has “Header row”
selected
o Selecting additional columns in the “Then by” fields can refine
sorting.
o Click the OK button to complete.
* Filtering data
o Click and drag through columns A through E.
o Data -> Filter -> AutoFilter
o Each column heading is now a drop-down list of options. Click on
each to view the options.
o To view all orders over $10,000
= Order Amount -> (Custom Filter...)
= Set Order Amount to “is greater than” and enter 10,000.
= C(lick OK.
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o To turn off AutoFilter: Data -> Filter -> select AutoFilter to
uncheck it.

Creating Charts

* (lick on the Website hits tab

* Select cells Al through E5 (entire table)

* Format the numbers with commas and no decimal places. (If you get
“H####4#” in a cell, widen the column until the numbers appear.)

* With entire table still selected, in the menu bar at the top select
Insert -> Chart. Note the ribbon and options that appear. Also note what
options have opened in the Toolbox’s Formatting Palette.

¢ Set the chart type to “Clustered Column.”

* Note the difference between selecting “Rows” and “Columns”. Leave it on
“Rows”.

* Add the title “Website Hits” to the chart.

* Locate the legend in a place that looks best to you.

Importing data
To import data into Excel each item needing its own cell needs to be delimited -
separated by a specific character. The most common delimiters used include:

* comma (")

* tab
* semicolon (“;")
* pipe (*|")

Importing exercise
In your current workbook:

1. File -> Import. In the Import Wizard leave the “CSV file” option selected
and click “Import”. Select the importl.csv file and click “Get Data.”

2. In Step 1 of the Text Import Wizard, make sure that the “Delimited”
option is checked, then click the “Next” button.

3. In Step 2 check the “Comma” option and uncheck all others.

4. In Step 3 change the “Column data format” for the first column to “Date:
MDY”, leaving all other columns as “General” data format.

Microsoft 2008 for Mac SOME RIGHTS RESERVED
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Text Import Wizard - Step 3 of 3

This screen lets you select each column and Column data format
set the Data Format.
@ General
‘General' converts numeric values to numbers, O Text
date values to dates, and all remaining values
to text. O pate: [MpY 4]
- B -
( Advanced Y\ (_) Do not import column (Skip)

Data preview

General General General
Description Driver Status
Missed Z-rider pickup mos, Jed closed 0
Gave directions to lost rider [Jones, Candice closed
No schedules available Carter, Ray closed
Excessive speed Jabuzzoff, Heywood [in arbitral,
Returned lost wallet Honest, Truly certificat(
4 >

( Cancel \ ( < Back \ (" Finish .1

5. Click Finish.
6. In “Import Data” select the “New worksheet” option, then click OK.

3
Import Data 1
1
|
Where do you want to put the data? m i
S i
O Existing sheet: — |
~ Cancel ) |
=5D51 = |
H
Properties... f
— = e
® New sheet i
PivotTable report ’a eters. |
| I I !
|

7. Right click on the tab for the worksheet you just created and select
“Rename”. Type the word “Transit” and press Enter.

Printing

¢ Printarea
o Click on “Transit” worksheet tab.
o Double-click between columns C & D, D & E, and E & F to AutoFit

text.

o To only print the first three columns select cells A1 through C8.
o File -> Print Area -> Set Print Area
o To preview, File -> Print, then click the “Preview” button.

* Print setup
o File->Page Setup -> Header/Footer tab

Microsoft 2008 for Mac SOME RIGHTS RESERVED
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o To add page numbering at the bottom of each page select “Page 1
of ?” from the “Footer:” drop-down menu
o Add a page title
= (lick the “Custom Header” button
= Center section: -> type “June Feedback”.
= (lick and drag over “June Feedback” and click the Font
button (“A”). Select a font style and size to suit.
= (lick OK, then click OK again.

Helpful functions

SUMIF(range,criteria,sum_range)

This function evaluates contents of cells in the first range to see if they meet a
certain criteria, which can be in the form of a number, expression, or text that
defines which cells will be added. If the criteria are met then the function will
add up the numeric contents of the corresponding cells in the sum_range.

For an explanatory example of this function click on the Bakery tab in your
workbook. Click on cell J6 to see this function in action. The SUMIF function is
checking all the cells from B2 to B25 to see if they contain the word “pastry” (not
case-sensitive). If that value is found then it adds the corresponding value in
cells E2 through E25 to the sum total.

To do the same for Buttercream:

* C(lick on cell J7 to select it

* Insert-> Function...

* In the “Search for a function” box type “SUMIF” (no quotes)

* Inthe “Select a function:” box double-click on “SUMIF".

* Inthe Function Arguments dialog box type the following values:
o Range ->B2:B25
o Criteria -> “buttercream” (with quotes)
o Sum_range -> E2:E25

* Press the Return key.

You can visually check to make sure the formula calculated correctly.

COUNTIF(range,criteria)

This function checks the contents of a range of cells against a given criteria. For
every cell that meets this criteria it increases a running tally or total by one (1),
and the result is the total number of cells meeting that criteria.

* Clickon cell [12 and type “Mixes”. Then press the Tab key. You should
now be in cell 113.

* In the menu bar select “Insert -> Function...” or click on the “Formula
Builder” palette in the Toolbox.

* Find the COUNTIF function and select it.

Microsoft 2008 for Mac SOME RIGHTS RESERVED
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| Al Area Bar Bubble (" Column_J Doughnut Line Pie Radar Stock Surface

|
Insert Chart

Pl RN TR .

< I B | G "D
1 Q1 Qz Q3 Q4
PAN East 221,909,875 287,502,345 192,003,245 346,004.789
BERN West 436,009.456 387,007.586 294,803,456 334,501,234
CI North 126,707,493 185,702,094 210,003,388 276,907.474
- South 374,004,567 26,820,020 482,603,300 596,003,765
z

* Function Arguments:
o Range ->A2:A25
o Criteria -> “mix”
* Press the Return key.

SE F G H 1 J K I8

You now have a count of the number of mixes the bakery carries.

Logical functions: IFERROR

X Y (Scatter)

This function returns a value that you specify if a formula evaluates to an error;

otherwise, it returns the result of the formula. The syntax is:
=IFERROR(value,value_if_error)

* (lick on the “Quotas” tab. This is a sales quota tracking worksheet for a

fictitious auto parts company.
* Format cells in column E so numbers display as percentages.

¢ (Calculate each person’s percent of quota by dividing Quota by Units Sold
by dividing C4 by D4, and put the result in E4. Use fill-down to complete it

quickly.
* Note the #DIVO! error message.
¢ Substitute =IFERROR(C4/D4,0) for the formula in E4.
¢ Use fill down to complete formulas for all rows.

Now the results do not display the error message.

Excel and Reporting

Pivot Tables
Spreadsheets can contain large amounts of data, which you might need to

rearrange and analyze to find trends and patterns. Pivot table reports can help

make sense of your data.

* Inthe Bakery tab select the entire table (A1l through F25).
* Data -> PivotTable
* In the Wizard make sure “Microsoft Office Excel list or database” and
“PivotTable” are selected.
* C(lick Next
* Range -> $A$1:$F$25
* C(lick Next
* In Step 3 click Finish.
* From the PivotTable Field List click & drag:
o Item Category -> Drop Column Fields Here
o Item Type -> Drop Row Fields Here
o Inventory -> Drop Data Items Here

Microsoft 2008 for Mac SOME RIGHTS RESERVED
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Now you have a report that provides an overview of what items you have in
inventory by category and type. To change fields in the table you must first drag
the existing field back to the table, and then drag the new one you want to the
table.

Q&A

Notes:

Microsoft 2008 for Mac SOME RIGHTS RESERVED
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Appendix
Keyboard shortcuts table

To

Press

Move right one cell

Press the Tab key or the right arrow key

Move left one cell

Press shift+Tab or the left arrow key

Move down one cell

Press the Return key or the down arrow
key

Move up one cell

Press shift+Return or the up arrow key.

Move down one full screen

Page Down (extended keyboard)
fn key + down arrow (laptop)

Move up one full screen

Page Up (extended keyboard)
fn key + up arrow (laptop)

Move right one full screen

Alt + Page Down (extended keyboard)
Option + Page Down (for Mac)

Move left one full screen

Alt + Page Up (extended keyboard)
Option + Page Up (for Mac)

Move to beginning of row

Home (extended keyboard)
fn key + left arrow (laptop)

Move to beginning of sheet

Control + Home (extended keyboard)
fn key + Control + left arrow (laptop)

Move to end of data on sheet

Control + End (extended keyboard)
fn key + Control + right arrow

Move to end of current row

Control + right arrow key

Move to end of current column

Control + down arrow key
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