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Introduction

Microsoft Excel is a spreadsheet application that features calculation, graphing tools
and other features for manipulation of alphanumeric data. It displays a vast area of cells
organized in rows and columns, and each cell contains data or a formula, with relative
or absolute references to other cells. It can contain any combination of types of data, but
is most commonly used for:

e numerical data: financial, statistical, date & time related
¢ charts: visual representation of data
* lists: helpful for tracking lists of information/data

Microsoft Excel files are easily recognized by the “.xls” file extension at the end of the
name (version 2003 and earlier for Windows, 2004 and earlier for Mac). In the 2007
version (2008 for Mac) it saves files with a “.xIsx” extension. For purposes of this
workshop we will only be working with the 2003 version.

Definitions:

* worksheet: single sheet of cells in 1,048,576 rows by 16,384 columns. Used
interchangeably with spreadsheet. You will probably never fill one up or break it
by putting too much into it.

* workbook: tabbed group of worksheets in a single file. The number of sheets is
limited only by the computing power of your computer.

* active cell: the cell bordered in dark, thick lines with a white background

* selecta cell (or cells): click on (or click and drag through) the cells you wish to
work with.

Cell labeling
Each cell is uniquely labeled and referred to by a combination of 1-3 letters (from “A” to
“XFD”) followed by a number from 1 to 1048576.



Getting Started

Keyboard shortcuts

To Press

Move right one cell Press the Tab key or the right
arrow key

Move left one cell Press shift+Tab or the left arrow
key

Move down one cell Press the Return key or the down
arrow key

Move up one cell Press shift+Return or the up
arrow key.

Move down one full screen Page Down

Move up one full screen Page Up

Move right one full screen Alt + Page Down (for Windows)
Option + Page Down (for Mac)

Move left one full screen Alt + Page Up (for Windows)
Option + Page Up (for Mac)

Move to beginning of row Home

Move to beginning of sheet Control + Home

Move to end of data on sheet | Control + End

Move to end of current row Control + right arrow key

Move to end of current Control + down arrow key

column

Open the file on your desktop labeled “exercises.xls”. Click on the “Allowance”
worksheet tab.

Exercise: teaching youth to save. An older child wants an increase in allowance
to buy a new video game. We are going to demonstrate that s/he already makes
enough money to buy the game if they save for it.
1. In the “Other” row, enter any dollar amount under $10 for each of the 4
weeks.
2. Type in the word “Total” just below the word “Other” in column A and
press “Tab” or the right arrow key to move to the next cell.
3. To instantly total a column or row of numbers in the active cell just click
. L= -
on the sigma symbol in the standard toolbar. After viewing the
formula to make sure it is correct press “Tab” or the right arrow key to
move to the next cell.



Toolbars and Menus
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o Standard: contains commands common to all Office programs plus the
most frequently used commands for Excel.

o Formatting: contains text formatting options plus some numeric quick-
format buttons
In Office 2007 /2008: added option of Formatting Palette

o Formula bar: enter and edit the contents of a cell in detail and a in a larger
view.

o To view the list of toolbars: View -> Toolbars
Back to the Allowance worksheet:

4. Finish creating totals for each column. Then add a column title after Week 4
labeled “Monthly Total”. Sum up the row horizontally so the total is in that
column.

5. To add the cents after the decimal and the dollar sign, click and drag through all

the cells containing the totals we created, then click on the dollar sign - in the
Formatting Toolbar.

Formatting, Formulas and Functions
The next exercises developed for this workshop are built around a fictitious medical

consulting business with you as the owner. Click on the “Fees” worksheet tab in your
open workbook.

Formatting cells

* Make text headings fit: double-click each column’s right border beside the letter

heading
* Decimals and commas
o Selectall cells with numbers

Format -> Cells...
Number tab -> Number
Decimal places: make sure it is set to 2
Check “Use 1000 Separator (,)”
Click the OK button.
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* Creating column headings centered in bold
o Select the cells with headings
o Click on the bold capital “B” and then on the center-text button in the
formatting bar. For more options use the “Format -> Cells...” menu.

Formulas structure

A formula or other calculation structure always begins with and equals sign (“="). In the
case of a function it is followed by the name of the function with left and right
parentheses enclosing the cells being referred to. For example,

=SUM(B2:B10)

will add up the numeric contents of cells B2 through B10. And the function
=AVG(C2:C21)

will average the numeric contents of cells C2 through C21.

Adding totals faster:

* Adda “Q totals” row heading after “South” and use the sigma to total only the
first column.

* Fill Right: Making sure cell B6 is still selected, place your cursor at the bottom-
right corner of the cell. It will change to a dark plus sign. Click and drag over 3
more columns and release the mouse button.

* (Click the check mark.

* Adda “Y totals” column heading after “Fourth Quarter” and use the sigma to total
the first row of figures.

* Fill Down: Making sure cell F2 is still selected, place your cursor at the bottom-
right corner of the cell. It will change to a dark plus sign like before. Click and
drag down 3 more rows and release the mouse button.

Handling large worksheets:
Click on the “Sales reportl” worksheet tab in your workbook. This is a spreadsheet
listing sales orders for a company serving the US and the UK.

* Freeze panes
o To keep the headings on the screen, click on cell C2
o Window -> Freeze panes.
o Now when you scroll up/down or right/left the column and row headings
stay visible.
* Sorting data by column
o Click on cell Al.
o Hold down the Control+Shift keys and press the End key. All data is now
selected.
o Data-> Sort
o In “Sort by” select “Order Amount” and “Descending” to see who had the
largest orders.
o Selecting additional columns in the “Then by” fields can refine sorting.
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Click the OK button to complete.

* Filtering data

@)
O
@)

O

Click and drag through columns A through E.
Data -> Filter -> AutoFilter
Each column heading is now a drop-down list of options. Click on each to
view the options.
To view all orders over $10,000
* Order Amount -> (Custom Filter...)
= Set Order Amount to “is greater than” and enter 10,000.
= (lick OK.
To turn off AutoFilter: Data -> Filter -> select AutoFilter to uncheck it.

* Hiding columns

@)
@)
@)

Click on the “News” tab.
Click and drag across columns C - D
Right-click on the selected columns and select the “Hide” option.

Creating Charts
¢ (lick on the Website hits tab
* Select cells Al through E5 (entire table)
* Format the numbers with commas and no decimal places.
e With entire table still selected, Insert -> Chart...

O
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Chart type: -> Column

Chart sub-type: -> Clustered column

Click “Press and Hold to View Sample” to preview your choice

Click “Next”.

Note the difference between selecting “Rows” and “Columns”. Leave it on
“Rows” and click “Next”.

Title tab -> Chart title: -> type in “Website Hits”

Legend tab -> Placement -> select option that looks best to you.

Click “Next”.

Note option to have chart placed on same page as table or in new tab.
Click Finish.

¢ Ifthe default placement of the title and legend do not suit simply click and drag
where you want them.

Importing data
To import data into Excel each item needing its own cell needs to be delimited -
separated by a specific character. The most common delimiters used include:

* comma (")

e tab

* semicolon (“;")
* pipe (*|")

Importing exercise
1. Inyour current workbook, Data -> Import External Data -> Import Data



Select the importl.csv file which can be found on the desktop, and click “Open”.
In the Import Wizard leave the “Delimited” option selected and click “Next”.

In Step 2 check the “Comma” option and uncheck all others.

In Step 3 change the “Column data format” for the first column to “Date: MDY”,
leaving all other columns as “General” data format.
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6. Click Finish.

In “Import Data” select the “New worksheet” option, then click OK.

8. Right click on the tab for the worksheet you just created and select “Rename”.
Type the word “Transit” and press Enter.

~

Printing
* Printarea
o Click on “Transit” worksheet tab.
o Double-click between columns C & D, D & E, and E & F to AutoFit text.
o To only print the first three columns select cells A1 through C8.
o File -> Print Area -> Set Print Area
o To preview, File -> Print Preview
* Print setup
o File -> Page Setup -> Header/Footer tab
o To add page numbering at the bottom of each page select “Page 1 of ?”
from the “Footer:” drop-down menu
o Add a page title
= (lick the “Custom Header” button
= Center section: -> type “June Feedback”.
= (lick and drag over “June Feedback” and click the Font button
(“A”). Select a font style and size to suit.
= (lick OK, then click OK again.



Helpful functions

SUMIF(range,criteria,sum_range)

This function evaluates contents of cells in the first range to see if they meet a certain
criteria, which can be in the form of a number, expression, or text that defines which
cells will be added. If the criteria are met then the function will add up the numeric
contents of the corresponding cells in the sum_range.

For an explanatory example of this function click on the Bakery tab in your workbook.
Click on cell J6 to see this function in action. The SUMIF function is checking all the cells
from B2 to B25 to see if they contain the word “pastry” (not case-sensitive). If that value
is found then it adds the corresponding value in cells E2 through E25 to the sum total.

To do the same for Buttercream:

* clickon cell J7 to select it

* Insert-> Function...

* In the “Search for a function” box type “SUMIF” (no quotes)

* Inthe “Select a function:” box double-click on “SUMIF”".

* Inthe Function Arguments dialog box type the following values:
o Range ->B2:B25
o Criteria -> “buttercream” (with quotes)
o Sum_range -> E2:E25

Click OK

You can visually check to make sure the formula calculated correctly.

COUNTIF(range,criteria)

This function checks the contents of a range of cells against a given criteria. For every
cell that meets this criteria it increases a running tally or total by one (1), and the result
is the total number of cells meeting that criteria.

Excel and Reporting

Pivot Tables
Spreadsheets can contain large amounts of data which you might need to rearrange and

analyze to find trends and patterns. Pivot table reports can help make sense of your
data.

* Inthe Bakery tab select the entire table (A1l through F25).

e Data -> PivotTable and PivotChart Report...

* In the Wizard make sure “Microsoft Office Excel list or database” and
“PivotTable” are selected.

* (lick Next

* Range -> $A$1:$F$25

* (lick Next



* In Step 3 click Finish.

* From the PivotTable Field List click & drag:
o Item Category -> Drop Column Fields Here
o Item Type -> Drop Row Fields Here
o Inventory -> Drop Data Items Here

Now you have a report that provides an overview of what items you have in inventory
by category and type. To change fields in the table you must first drag the existing field
back to the table, and then drag the new one you want to the table.

Q&A

Notes:
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Appendix
Keyboard shortcuts table

To Press
Move right one cell Press the Tab key or the right
arrow key
Move left one cell Press shift+Tab or the left arrow
key

Move down one cell

Press the Return key or the down
arrow key

Move up one cell

Press shift+Return or the up
arrow key.

Move down one full screen

Page Down

Move up one full screen

Page Up

Move right one full screen

Alt + Page Down (for Windows)
Option + Page Down (for Mac)

Move left one full screen

Alt + Page Up (for Windows)
Option + Page Up (for Mac)

Move to beginning of row

Home

Move to beginning of sheet

Control + Home

Move to end of sheet

Control + End
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This work is licensed under the Creative Commons Attribution-Noncommercial-Share

Alike 3.0 United States License. To view a copy of this license, visit
http://creativecommons.org/licenses/by-nc-sa/3.0/us/ or send a letter to Creative

Commons, 171 Second Street, Suite 300, San Francisco, California, 94105, USA.
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