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Introduction

Microsoft Excel is a spreadsheet application that features calculation, graphing
tools and other features for manipulation of alphanumeric data. It displays a vast
area of cells organized in rows and columns, and each cell contains data or a
formula, with relative or absolute references to other cells. It can contain any
combination of types of data, but is most commonly used for:

e numerical data: financial, statistical, date & time related
* charts: visual representation of data
* lists: helpful for tracking lists of information/data

Microsoft Excel files are easily recognized by the “.xls” (version 2003 and earlier
for Windows, 2004 and earlier for Mac) or “xlIsx” (version 2007 for Windows,
2008 for Mac) file extensions at the end of the name. The second “x” stands for
eXtensible Markup Language (XML), a set of rules for coding documents
electronically used extensively on the Web.

Definitions:

* worksheet: single sheet of cells in 1,048,576 rows by 16,384 columns.
Used interchangeably with spreadsheet. You will probably never fill one
up or break it by putting too much into it.

* workbook: tabbed group of worksheets in a single file. The number of
sheets is limited only by the computing power of your computer.

* active cell: the cell bordered in dark, thick lines with a white background

* selecta cell (or cells): click on (or click and drag through) the cells you
wish to work with.

Cell labeling

Each cell is uniquely labeled and referred to by a combination of 1-3 letters
(from “A” to “XFD”) followed by a number from 1 to 1048576. You can tell what
cell you are working on by the display in the Name Box:
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Getting Started

Interface parts
1. General user interface: the Ribbon
2. Office button
3. Quick Access Toolbar

Ribbon
J/ =
- Home Insert Page Layout References Mailings Review View Developer ©
Eurostile |22 ~ % oY
B I U - abe x, x| AaBbCcl| AaBbCi AaBbCcl = /%
; S 7 = TNormal | Headingl Heading2 - Change Editing
|||~ A~ Aa-||A A $r - i |2 9T ¢ 92 |5 sytes~ ||
Clipboard ™ Font ] Paragraph F] Styles F]

* Instead of using the menus (which Microsoft helped to standardize) they
have created tabbed “groups” of similar features. Adding software that
interacts with Office programs will create additional tabs or add to the
“Add-Ins” tab (if it already exists).

* Tabs include a “Dialog Expander” button at the bottom-right of some
groups.

* Addition of the “Style Galleries:”

o When the window is resized this part of the ribbon will shrink or
expand accordingly

o “Live preview” feature: when you mouse over a selection in the
gallery the area it affects will temporarily change to that selection.

o Each gallery has a drop-down menu, accessible by button at
bottom-right.

* Keyboard shortcuts:

o Allregular shortcuts remain (copy, paste, etc.), plus the “Alt” key
now toggles ribbon shortcuts on, “Esc” key toggles this off.
o Minimize the ribbon: Control+F1

Office Button
- * Contains functions previously under the “File” menu.
Ca * Customize each application’s settings here.

-
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Quick Access Toolbar

Microsoft Office used to be almost fully customizable, but it is

= * now restricted to the selections under the Office Button, and
this toolbar.

e [t can be placed above or below the Ribbon.

* The default configuration contains Undo, and because it is context
sensitive it adds Redo and Repeat when available.

* (Can add any commands you frequently use here.

Other features

* Right-click menu looks different with more options.

* Opening a file in an older format puts “[Compatibility Mode]” in the
document title. The file format for this document defaults to the newer
formats ending in “x”:

o .docx-Word

o .xlsx - Excel

o .pptx - PowerPoint
Hover hints are longer, and more descriptive
Help relocated to far right; click on the circled question mark.

Page layout view (button @ bottom).
Increased formatting power: themes, more colors, conditional formatting
expanded from 4.

Tips for a mixed environment:
1. Learn how different versions interact. Comparison tool available at
Microsoft’s website (http://tinyurl.com/yhmmqgbv).
2. Create files in the most common version.
3. Install the Office 2007 compatibility pack from the Microsoft website if
you use an earlier version of Office.

(Continued on next page.)
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Settings

To adjust preferences in Excel:

Office Button -> Excel Options button (lower right corner)

'r Popular
Formulas
Proofing
Save
Advanced
Customize
Add-Ins
Trust Center

Resources

1

™
L@ Change the most popular options in Excel.

Top options for working with Excel

[V show Mini Toolbar on selection (i
[V Enable Live Preview (i

v Show Developer tab in the Ribbon i
[V Always use ClearType

Color scheme: Blue vl

ScreenTip style: I Show feature descriptions in ScreenTips LI

Create lists for use in sorts and fill sequences: Edit Custom Lists... |
When creating new workbooks

Use this font: |Body Font ;l

Font size: 11 ~«

Default view for new sheets: I Normal View v l
Include this many sheets: |3 3‘

Personalize your copy of Microsoft Office

User name: IR. Todd Vandenbark

Choose the languages you want to use with Microsoft Office: ~ Language Settings... I

OK I Cancel

Z

Here you can add shortcuts to the Quick Access Toolbar, adjust spell-checking
options, set the default font size and more.

(Continued on next page)
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Customizing Quick Access Toolbar

1. Office Button -> Excel Options button (lower right corner of dialog box)

-> Customize

I Excel Options

Popul L ) !
bl @ Customize the Quick Access Toolbar.
Formulas

Choose commands from: Customize Quick Access Toolbar: (i

Proofin
roofing IPopuIar Commands

&

I For all documents (default)
Save

<Separator> A Save

Advanced

Customize

Calculate Now
Calculate Sheet
Create Chart

Undo
Redo
Set Print Area

D230

Add-Ins
Custom Sort...

Datasheet Formatting
Delete Cells...

Delete Sheet Columns
Delete Sheet Rows
E-mail

Insert Cells...

Insert Hyperlink
Insert Picture from File
Insert PivotTable
Insert Sheet Columns
Insert Sheet Rows
New

Open

Paste Special...

Print Preview

Quick Print

Redo 4
Repeat

Save

Set Print Area

Sort Ascending

Sort Descending
Spelling...

Trust Center

Resources

Add >> |

Remove

R SR 7 o T W S AL R e 4 S T
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O Show Quick Access Toolbar below the Ribbon

Cancel

Scroll until you see the Print Preview and click to select it.

Click the Add >> button between the two columns.

Repeat for Set Print Area.

Click OK. Now your Quick Access Toolbar has two more options in it.

v Wi

You can add other frequently-used commands as well by selecting from the
Choose commands from drop-down menu, then selecting the tab group the
command is normally found in.

o
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Keyboard shortcuts

To Press

Move right one cell Press the Tab key or the right arrow key

Move left one cell Press shift+Tab or the left arrow key
Press the Return key or the down arrow

Move down one cell key

Move up one cell Press shift+Return or the up arrow key.

Move down one full screen Page Down

Move up one full screen Page Up

Move right one full screen Alt + Page Down

Move left one full screen Alt + Page Up

Move to beginning of row Home

Move to beginning of sheet Control + Home

Move to end of data on sheet Control + End

Move to end of current row Control + right arrow key

Move to end of current column | Control + down arrow key

(Table repeated @ back of this packet for easy tear-off.)

Exercises

Open the file on your desktop labeled “exercises.xlsx”. Click on the “Allowance”
worksheet tab.

Teaching youth to save
An older child wants an increase in allowance to buy a new video game. We
are going to demonstrate that s/he already makes enough money to buy the
game if they save for it.
1. In the “Other” row, enter any dollar amount under $10 for each of the 4
weeks.
2. Type in the word “Total” just below the word “Other” in column A and
press “Tab” or the right arrow key to move to the next cell.
3. To instantly total a column or row of numbers in the active cell just click
on the AutoSum button (the Greek letter Sigma) in the
formatting toolbar. After viewing the formula to make sure it is 2 AutoSum
correct press “Tab” or the right arrow key to move to the next
cell.
4. Finish creating totals for each column. Then add a column title after Week
4 labeled “Monthly Total”. Sum up the row horizontally so the total is in
that column.
5. To add the cents after the decimal and the dollar sign, click and drag
through all the cells containing the totals we created, then click on the
dollar sign in the Formatting Toolbar.
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Formatting, Formulas and Functions

The next exercises developed for this workshop are built around a fictitious
medical consulting business with you as the owner. Click on the “Fees”
worksheet tab in your open workbook.

Formatting cells
* Make text headings fit: double-click each column’s right border beside the
letter heading
* Add decimals and commas by clicking on the comma button in the
Formatting Toolbar.
* Creating column headings centered in bold
o Select the cells with headings
o Click on the bold capital “B” and then on the center-text button in
the formatting bar. For more options use the “Format -> Cells...”
menu.

Formulas structure

A formula or other calculation structure always begins with and equals sign
(“="). In the case of a function it is followed by the name of the function with left
and right parentheses enclosing the cells being referred to.

For example,
=SUM(B2:B10)

will add up the numeric contents of cells B2 through B10. And the function
=AVG(C2:C21)

will calculate the average of the numeric contents of cells C2 through C21.

Adding totals faster:

* Adda “Q totals” row heading after “South” and use the sigma to total only
the first column.

* Fill Right: Making sure cell B6 is still selected, place your cursor at the
bottom-right corner of the cell. It will change to a dark plus sign (“4”).
Click and drag over 3 more columns and release the mouse button. Note
the “Auto Fill” icon that appears at the end of the row. This will allow you
to adjust your Fill Right as needed (Fill Right is a form of copy-and-paste.)

¢ (lick the check mark or press Enter.

* Adda “Y totals” column heading after “Fourth Quarter” and use the sigma
to total the first row of figures.

* Fill Down: Making sure cell F2 is still selected, place your cursor at the
bottom-right corner of the cell. It will change to a dark plus sign like
before. Click and drag down 3 more rows and release the mouse button.

.
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Handling large worksheets:
Click on the “News” worksheet tab in your workbook. This spreadsheet shows
data downloaded from a web server, with many, many columns and rows.

* Freeze panes:
o To keep the row and column headings on the screen click on cell
B2.
o View tab -> Freeze panes.

;—El =] Split ] View Side by Side -
~— Hide 1; Synchronous Scrolling j"
Freeze | ) Save
Panes ~ D A T P S L e S

nide  Reset N1dow FOSITIC Workspac

Freeze Panes |
H Keep rows and columns visible while the rest of i
a the worksheet scrolls (based on current selection). L
Freeze Top Row
Keep the top row visible while scrolling through
the rest of the worksheet.
Freeze First Column
Keep the first column visible while scrolling

through the rest of the worksheet.

o Now when you scroll up/down or right/left the column and row

headings stay visible.
* Hiding columns

o Click and drag across columns C - D, or click on column C and shift
+ click on D.

o Right-click (or Control + click) on the selected columns and select
the “Hide” option. Columns C and D are now hidden, and columns
A and E have bold, blue lettering to show where columns have
been hidden.

o Toshow C & D, click and drag across columns A and E, right-click
(or Control + click) on the column headings and select “Unhide.”
You can now see all columns.

Sorting data

Click on the “Sales report1” worksheet tab in your workbook. This is a
spreadsheet listing sales orders for a company serving the US and the UK.

* To keep the headings on the screen, click on cell C2 and use “Freeze
panes.”

* Sorting data by column
o Click on cell Al.
o Hold down the Control+Shift keys and press the End key. All data
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is now selected. If you are using a laptop or other keyboard
without an End key, hold down Control+Shift and press the down
arrow key followed by the right arrow key (without releasing the
Control+Shift combination). Release the Control and Shift keys.

o Data-> Sort
o Inthe “Sort” menu select “Order Amount” and “Largest to
smallest” to see who had the largest orders.
= Ifyou have selected the row of headings, make sure “My
data has headers” checkbox is checked.
o Selecting additional columns in the “Then by” fields can refine
sorting.
o Click the OK button to complete.
Filtering data
o Click and drag through columns A through E.
o Data -> Filter -> AutoFilter
o Each column heading is now a drop-down list of options. Click on
each to view the options.
o To view all orders over $10,000
* Order Amount -> (Custom Filter...)
= Set Order Amount to “is greater than” and enter 10,000.
= (lick OK.
o To turn off AutoFilter: Data -> Filter -> select AutoFilter to

uncheck it.

Creating Charts

Click on the Website hits tab

Select cells A1 through E5 (entire table)

Format the numbers with commas and no decimal places. (If you get
“H####4#” in a cell, widen the column until the numbers appear.)
With entire table still selected: Insert tab -> Charts

Note the ribbon and options that appear.

Helpful cue:

O

Note the green-highlighted “Chart Tools” at the top of the window.

Set the chart type to “Clustered Column.”

Note the difference between selecting “Rows” and “Columns”. Leave it on
“Rows”.

Add the title “Website Hits” to the chart by clicking on the Title button.
Locate the legend in a place that looks best to you.

o
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Importing data
To import data into Excel each item needing its own cell needs to be delimited -

separated by a specific character. The most common delimiters used include:

e tab

comma (“")

* semicolon (“;")
* pipe (*|")

Importing exercise
1. Inyour current workbook:
a. Office Button -> Open. Select the import1l.csv file and click “Open”.

b.

Excel for Windows automatically converts and imports the file.

In Step 1 of the Text Import Wizard, make sure that the

“Delimited” option is checked, and then click the “Next” button.

21|
The Text Wizard has determined that your data is Delimited.
If this is correct, choose Next, or choose the data type that best describes your data.
iginal data type

type that best describes your data:
- Characters such as commas or tabs separate each field.
dth - Fields are aligned in columns with spaces between each field.

Chwsg_

Startimportatrow: |1 =] File origin: | 437 : OEM United States |

Preview of file C:\Documents and Settings\toddv\Desktop\import1.txt.

1 PpateOTypeODescriptionODriverOStatus =
2 6/1/090complaintiMissed 2-rider pickupO"Amos, Jed"Oclosed

3 16/1/090kudosOGave directions to lost riderO"Jones, Candice"Oclosed

4 16/2/090complaintlNe schedules availableO"Carter, Ray"Oclosed

5 16/4/090complaintOExcessive speedO"Jabuzzoff, Heywood"Oin arbitration wit]lw
4 | »

In Step 2 check the “Tab” option and uncheck all others.

(continued on next page)
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Text Import Wizard - Step 2 of 3

21

This screen lets you set the delimiters your data contains. You can see how your text is affected in the preview
below.
rDelimiters

v Tab

[~ Semicolon [~ Treat consecutive delimiters as one

[~ comma

= Text gualifier: I' v[

I Space

[~ other: l
~Data preview

ate Type escription river tatus -

/1/039 pomplaint Missed 2-rider pickup os, Jed losed

/1/09 kudos ave directions te lost rider [Jones, Candice losed

/2/09 komplaint No schedules available arter, Ray losed

/4/039 pomplaint Excessive speed abuzzoff, Heywood [in arbit]w

| | »

Cancel <gack | Ensh |

In Step 3 change the “Column data format” for the first column to
“Date: MDY”, leaving all other columns as “General” data format.

Text Import Wizard - Step 3 of 3

2|
This screen lets you select each column and set the Data Format.
olumn data format
" General . ;
- General' converts numeric values to numbers, date values to dates, and all
Text remaining values to text.
9 MDY j Advanced...
" Do not import column (skip)
rData preview
M Ceperzl zal
D. Description Priver Status o
& Missed Z-rider pickup Rmos, Jed closed
e IFave directions to lost rider [Jones, Candice closed
(5 o schedules available Carter, Ray closed
e xcessive speed Jabuzzoff, Heywood [in arbit LI
| i
Cancel <gack | weas [[ Emsh |

e. Click Finish.

2. To move this worksheet to our exercises workbook: 20|

a. Right-click on the tab for this worksheet and Move seleced shets
Iexerdses.xisx j
Before sheet:

Allowance =[
Fees
News

~ Sales report1
UNIVERSITY OF UTAH i Website hits
U SPENCER S. ECCLES Baker:
HEALTH SCIENCES LIBRARY > N = _l
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I~ Create a copy




select “Move or Copy”.
b. In the “Move selected sheets” dialog box:
* To book: exercises.xIsx
* Before sheet: (move to end)
3. The new worksheet is now in our main workbook.
4. Right click on the tab for the worksheet you just created and select
“Rename”. Type the word “Transit” and press Enter.

Printing
* Printarea
o Click on “Transit” worksheet tab.
o Widen all columns until they are readable.
o To only print the first three columns select cells A1 through C8:
= Select entire table
= Page View tab -> Print Area -> Set Print Area
o To preview, Office Button -> Print -> Print Preview
* Print setup
o Inserttab -> Header & Footer
o Type the title “June Feedback” in the Header area. To add
formatting to the title, click the Home tab to do your formatting.
o To add page numbering at the bottom of each page:
= Inserttab -> Header & Footer
= Design tab -> Header & Footer group -> Footer ->
Page 1 of ? option.
* Preview your work: Office Button -> Print -> Print Preview.

Helpful functions

SUMIF(range,criteria,sum_range)

This function evaluates contents of cells in the first range to see if they meet a
certain criteria, which can be in the form of a number, expression, or text that
defines which cells will be added. If the criteria are met then the function will
add up the numeric contents of the corresponding cells in the sum_range.

For an explanatory example of this function click on the Bakery tab in your
workbook. Click on cell J6 to see this function in action. The SUMIF function is
checking all the cells from B2 to B25 to see if they contain the word “pastry” (not
case-sensitive). If that value is found then it adds the corresponding value in
cells E2 through E25 to the sum total.

To do the same for Buttercream:

* C(lick on cell J7 to select it
* Insert-> Formulas
* In the “Search for a function” box type “SUMIF” (no quotes)
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In the “Select a function:” box double-click on “SUMIF”.

In the Function Arguments dialog box type the following values:
o Range ->B2:B25
o Criteria -> “buttercream” (with quotes)
o Sum_range -> E2:E25

Click OK

You can visually check to make sure the formula calculated correctly.

COUNTIF(range,criteria)

This function checks the contents of a range of cells against a given criteria. For
every cell that meets this criteria it increases a running tally or total by one (1),
and the result is the total number of cells meeting that criteria.

Click on cell 112 and type “Mixes”. Then press the Tab key. You should
now be in cell 113.
Insert -> Formulas
Find the COUNTIF function and select it.
Function Arguments:
o Range ->A2:A25
o Criteria -> “mix”
Click OK or press Enter.

You now have a count of the number of mixes the bakery carries.

Logical functions: IFERROR
This function returns a value that you specify if a formula evaluates to an error;
otherwise, it returns the result of the formula. The syntax is:

=IFERROR(value,value_if_error)

Click on the “Quotas” tab. This is a sales quota tracking worksheet for a
fictitious auto parts company.

Format cells in column E so numbers display as percentages.

Calculate each person’s percent of quota by dividing Quota by Units Sold
by dividing C4 by D4, and put the result in E4. Use fill-down to complete it
quickly.

Note the #DIVO! error message.

Substitute =IFERROR(C4/D4,0) for the formula in E4.

Use fill down to complete formulas for all rows.

Now the results do not display the error message.

Excel and Reporting

Pivot Tables
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Spreadsheets can contain large amounts of data, which you might need to
rearrange and analyze to find trends and patterns. Pivot table reports can help
make sense of your data.

* Inthe Bakery tab select the entire table (A1l through F25):
o Insert-> PivotTable (Windows)
* From the PivotTable Field List click & drag:
o Item Category -> Drop Column Fields Here
o Item Type -> Drop Row Fields Here
o Inventory -> Drop Data Items Here

Now you have a report that provides an overview of what items you have in
inventory by category and type. To change fields in the table you must first drag
the existing field back to the table, and then drag the new one you want to the
table.

Q&A

Notes:
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Appendix
Keyboard shortcuts table

To

Press

Move right one cell

Press the Tab key or the right arrow key

Move left one cell

Press shift+Tab or the left arrow key

Move down one cell

Press the Return key or the down arrow key

Move up one cell

Press shift+Return or the up arrow key.

Move down one full screen

Page Down

Move up one full screen

Page Up

Move right one full screen

Alt + Page Down

Move left one full screen

Alt + Page Up

Move to beginning of row

Home

Move to beginning of sheet

Control + Home

Move to end of sheet

Control + End
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